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Error "Unable to connect to the file "<file path>".  Check that the file exists and that you have sufficient access privileges for it." Refreshing Extract


Published: 14 May 2015
Last Modified Date: 06 Jan 2017

Issue

When refreshing an extract of an Excel file that is located on a network drive, the extract might fail and the following error appears in the Background Task view:

com.tableausoftware.nativeapi.dll.DataSourceException: Unable to connect to the file "<file path>".  Check that the file exists and that you have sufficient access privileges for it.

Environment

  • Tableau Server
  • Excel

Resolution

Update the data connection(s) in Tableau Desktop to reflect the UNC path to the Excel workbook, instead of a file path that includes a mapped drive letter, and republish the workbook.

Cause

The path to connect to the data source is using a mapped path. Tableau Server uses the Run As user account to authenticate a data source. Because the Run As user account cannot access resources that have been authenticated in the security context of another user, it cannot use the mapped path.
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