KNOWLEDGE BASE

Error: "Unable to Connect to Published Data Source" When Opening a Workbook Connected to a Text Base Data Source


Published: 23 Aug 2017
Last Modified Date: 24 Aug 2017

Issue

After publishing workbook that has a connection to text base data source, the following error might occur after you attempt to open the workbook via your browser.
"Unable to connect to the data source"
 
Additionally, the following errors might occur: 
 
Tableau Data Engine Error:320: <path >
The table "[TableauTemp].[filename]" does not exist.
or 
Tableau Data Engine Error: 504: <path> 
The table "[TableauTemp].[filename]" does not exist.
or 
Tableau Data Engine Error: 40696: The system can not find the specified file. 
- DataFile :: DataFile (CreateFileWrapper path = <path>) Could not create file handle. 
The table "[<table name>]" does not exist. 
or
Invalid database name value.

 

Environment

  • Tableau Server
  • Text Data Source
  • UNC path
  • Live Connection
  • File Sharing Application (e.g. Box Sync)

Resolution

Work with your IT team to confirm that the file path used in Tableau to retrieve the data source and the actual path of the data source stored on the computer match. 

To do so, please follow the steps below: 
  1. Login to the computer where the original data source is stored.
  2. Go to the folder where the data source exists via file the explorer.
  3. Verify the file path. This path should be used to connect to the data source via Tableau. 

Cause

The workbook contains the directory of the data source based on the connection information. If a file sharing application is used (e.g. Box) and the file path is similar to the examples below, the underlying data source will fail to connect and the error(s) will occur.
  • Tableau Desktop (or Client side) - \\hostname\Data Source
  • On File Server -  C:\User\Administrator\Box Sync\Data Source
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