KNOWLEDGE BASE

Error "This file is in use." When Attempting to Open or Refresh a file hosted on OneDrive


Published: 20 Apr 2018
Last Modified Date: 23 Apr 2018

Issue

When attempting to connect to a file hosted on OneDrive, the following error occurs:

<file name>
This file is in use.
Enter a new name or close the files that's open in another program.


Additionally, when attempting to refresh a file hosted on OneDrive, the following error occurs:

Unable to open file: '<file path>': The process cannot access the file because it is being used by another process.

 

Environment

  • Tableau Desktop 10.4, 10.5
  • Excel
  • Microsoft OneDrive

Resolution

Option 1

Make sure no files from OneDrive are open in Microsoft Excel at the same time Tableau Desktop is opened.

Option 2

Work with your IT team to edit the OneDrive settings to not synchronize the files.
  1. Right-click on the OneDrive name (left pane of Window File Finder) and select Settings.
  2. Navigate to the Office tab.
  3. Deselect "Use Office 2016 to sync Office files that I open" option
  4. Click OK.
  5. Close out of any open Excel files and re-open for changes to take effect.

Cause

The file is opened in Excel at the same time Tableau Desktop is open. OneDrive locks read access for other programs when the "Use Office 2016 to sync Office files that I open" setting is selected and the file is open in Excel.
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