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Error "There is no disk in the drive. Please insert a disk into drive <drive>" When Connecting to a Data Source


Published: 09 Feb 2018
Last Modified Date: 09 Feb 2018

Issue

In Tableau Desktop, when connecting to a data source, the following error occurs:

tabprotosrv.exe - no disk
There is no disk in the drive. Please insert a disk into drive D:

Please note that:
  • This error is benign as it will not prevent any further action in Tableau Desktop, but can become annoying.
  • This error does not originate from Tableau Desktop but from Windows. The process name and drive referenced may be different.

Environment

  • Tableau Desktop 
  • Windows 10

Resolution

This error is not specific to Tableau and has no single cause or resolution. You may need to consult your organization's IT team for more assistance. The below suggestion might resolve the issue: 

Work with your IT team to have the USB Mass Storage Device disabled in the Windows Device Manager settings: 
  • Open Windows Device Manager from Control Panel
  • Open up the Universal Serial Bus controllers group
  • Right-click on the 'USB Mass Storage Device' item
  • Choose 'Disable'

For more information about this resolution, please see the following third party link: "There is no disk in the drive. Please insert a disk into drive E:"?
 

Cause

This error is not specific to Tableau Desktop, a possible causes of this error includes: 
A removable drive is likely not connected to any device but is still showing on the computer.

 
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