KNOWLEDGE BASE

Error: "There is no active connection to the data source" When Refreshing Published Snowflake Extracts Using tableau refreshextract


Published: 14 Mar 2017
Last Modified Date: 30 Oct 2017

Issue

When refreshing a published Snowflake extract using the Tableau Data Extract Command-Line Utility, command tableau refreshextract, the following error might occur:
"There is no active connection to the data source"

Environment

  • Tableau Desktop
  • Snowflake

Resolution

Option 1

Upgrade to Tableau Desktop 10.2.2 or 10.1.8. For more information, see Upgrading Tableau Desktop.

Option 2

Schedule Snowflake extract refreshes from Tableau Server (or Tableau Online).

Cause

This behavior is related to a known issue (ID: 628610) which has been fixed in a recent Tableau Desktop version.
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