KNOWLEDGE BASE

Error "There is no active connection to the data source" Refreshing Web Data Connector Using Sync Client


Published: 21 Sep 2016
Last Modified Date: 17 Jan 2017

Issue

When trying to refresh a published Web Data Connector (WDC )extract that uses basic authentication using Sync Client, the following error might occur:
 
 Could not refresh data source. If the issue persists, contact Tableau Support
there is no active connection to the data source

Environment

  • Tableau Online
  • Web Data Connector
  • Sync Client 10.0.0 - 10.0.3, and 10.1.0 - 10.1.1

Resolution

Upgrade Tableau Desktop and Sync Client to the 10.0.5, 10.1.3, or a newer version. See Upgrade Tableau Desktop for more information. 

Cause

The ability to refresh Web Data Connectors with the Tableau Online Sync Client was added in the 10.0.5 and 10.1.3 releases.
Did this article resolve the issue?