KNOWLEDGE BASE

Error "The installation failed." Installing FLEXnet on a Mac


Published: 16 Feb 2016
Last Modified Date: 18 Aug 2016

Issue

When you try to launch Tableau Desktop, an error message instructs you to install FLEXNet directly from Tableau FLEXNet.pkg.
When you try to install FLEXNet, the following error occurs:

The installation failed.
The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

User-added image

Environment

  • Tableau Desktop 9.2.4 and earlier versions
  • Mac OS X

Resolution

Option 1:

Upgrade to Tableau Desktop 9.0.13, 9.1.7, 9.2.5 or a newer version. For more information, see Upgrading Tableau Desktop.

Option 2:

For previous versions of Tableau Desktop, download the renewed certificate directly on the applicable Mac computer.
  1. Download and install the updated certificate from the following location: https://developer.apple.com/certificationauthority/AppleWWDRCA.cer
  2. For more information, see Keychain Access: add certificates to a keychain  in the Apple knowledge base.
  3. In Keychain Access, select View > Show expired certificates
  4. Remove the expired Apple Worldwide Developer Relations Certification Authority certificate from the keychain. 
  5. Attempt the Tableau FLEXNet.pkg installation again.
The above steps should allow FLEXNet to successfully install. In some cases, it may be necessary to explicitly trust the new certificate.


 

Cause

The Apple Developer Certificate used in previous Tableau Desktop for Mac installers expired on February 14, 2016.
Did this article resolve the issue?