KNOWLEDGE BASE

Error "The field does not exist in the database" on Group Dimensions When Data is Updated


Published: 12 Jun 2014
Last Modified Date: 09 Sep 2015

Issue

When refreshing an extract, opening and closing a workbook, or switching to a live connection, some dimensions are marked invalid and the following error might display when hovering over them:
 
The field does not exist in the database

Environment

Tableau Desktop 8.1

Resolution

Contact your database administrator to have the affected fields added to the database as new fields.

 

Cause

Groups were being used to create new fields that did not exist in the database. For example, a Customer field was being used to group customers according to the State in which they live, thus creating a new State field.

SQL imposes a limit on the length of a query statement and creating groups, such as the one described above, can create a string that exceeds this limit.
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