KNOWLEDGE BASE

Error "the account is currently locked out" or "A name is required but was passed as NULL" Opening Workbook


Published: 02 Oct 2014
Last Modified Date: 21 Nov 2014

Issue

When you try to open a workbook with embedded database user name and password, one of the following errors might occur:
 
An error occurred while communicating with Microsoft SQL Server Database.
Invalid username or password.

[Microsoft][SQL Server Native Client 11.0][SQL Server]Login failed for user '<username>'.

Or
 
[Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed for user '<username'> because the account is currently locked out. The system administrator can unlock it. ", 'sql-state': '42000', 'error-record': 1, 'sql-state-desc': 'SQLSTATE_QUERY_SYNTAX_ERROR', 'native-error': 18486}]

Or
 
throw DataSourceException (type=BadPassword): [Teradata][ODBC Teradata Driver] Major Status=0x1000000 Minor Status=0xe3000205-Inaccessible read 
[Teradata][ODBC Teradata Driver] Major Status=0x1000000 Minor Status=0xe3000205-A name is required but was passed as NULL. 
[Teradata][ODBC Teradata Driver] 
[Teradata][ODBC Teradata Driver] Unable to logon with Authentication Mechanism selected.

Environment

  • Tableau Desktop 8.2.0 - 8.2.4
  • Microsoft SQL Server, Netezza or Teradata

Resolution

Upgrade to Tableau Desktop 8.2.5 or a later version. For more information, see Upgrading Tableau Desktop in the Tableau Knowledge Base.

Cause

This behavior is a known issue that has been corrected in more recent releases.
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