KNOWLEDGE BASE

Error: "Tableau Server Installation Error: Unable to run nested installer'" When Running Tableau Server Installer


Published: 22 Jun 2017
Last Modified Date: 23 Jun 2017

Issue

When running the Tableau Server Installer, the following error  might occur and the installer fails
"Tableau Server Installation Error: Unable to run nested installer'

Environment

  • Tableau Server 10.2.2
  • Windows Server 2012 R2

Resolution

Ensure the following:
  • Ensure that, when installing Tableau Server, the minimum system requirements are met, particularly disk space. See the Tableau Server Technical Specifications for more information.   
  • Ensure that when installing Tableau Server, the installation package is right clicked and 'Run As Administrator' is selected to ensure that Windows User Account Controls is not preventing the installation package from writing to the registry. 
  • You have Administrative rights to the machine you are attempting to install Tableau Server to.
  • You have "write" file access to the file path you are installing Tableau Server to.
  • Verify that there is no Antivirus software, Security software (such as Bit 9 Agent) or Group Policy Object specifically denying installation permissions.
  •  Ensure that Windows User Account Control is disabled when attempting to install Tableau Server. 

Cause

This issue might occur when there is an error making file system and registry changes to a machine via an Installer file. installer. 

Additional Information

  • The Tabadmin.log is generally vague in these instances, but can contain a generic entry such as this: "Received ExitWithStatus, code 2"
  • A useful indicator if this is a permissions issue can be found in the Microsoft Windows Security log.
    1. Go to Start > event viewer on the computer
    2. Open "windows logs> Security"
    3. Look for an informational event with the ID "4656" during the time frame the install attempt was made. If you see this and it contains the keyword "audit failure" this is Windows specifically logging a denial of permissions.
Did this article resolve the issue?