KNOWLEDGE BASE

Error "Tableau server expected to find driver version 8.3.0" When Refreshing Extract


Published: 25 Aug 2014
Last Modified Date: 12 Nov 2015

Issue

When refreshing an EMC Greenplum extract or editing the connection on Tableau Server, the following error might occur:

Tableau Server expected to find driver version 8.3.0 to connect to the database server '<Database Server>', but version 7.1.0 is installed. Visit http://www.tableausoftware.com/drivers to download driver setup files.

Environment

  • Tableau Server 8.2
  • EMC Greenplum

Resolution

Option 1

Upgrade to Tableau Server 8.2.3 or later version. Fore more information, see Upgrading Tableau Server.

Option 2

  • Download and install the PostgresSQL (32-Bit) drivers on all computers running Tableau Server background tasks, vizqlserver, or dataserver services. To download the drivers, see Tableau's Drivers & Activation page
  • Restart all affected computers. 

Cause

The workbook or extract was originally published using the Postgres Unicode driver instead of the DataDirect drivers. The Postgres Unicode driver is not installed on the computer running the background tasks. 
Did this article resolve the issue?