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Error "Schema has changed since the time the extract was created" Refreshing Salesforce Extract


Published: 17 Jul 2014
Last Modified Date: 24 Jul 2017

Issue

When you try to refresh a Salesforce extract in Tableau Desktop, the following error might occur:

Not all extracts were refreshed

An error occurred while refreshing <data source>
Schema has changed since the time the extract was created

Environment

  • Tableau Desktop 
  • Salesforce

Resolution

  1. Recreate the extract. For more information, see Extracting Data in Tableau Help.
  2. Replace the extract in the workbook with the new extract. For more information, see Replacing Data Sources.

Cause

The Salesforce object or its metadata has changed. Fields might have been added or removed.
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