KNOWLEDGE BASE

Error "REXML::ParseException: The 'xml' prefix must not be bound to any other namespace" When Upgrading


Published: 19 Aug 2016
Last Modified Date: 13 Oct 2016

Issue

When upgrading to Tableau Server 10.0 from 9.2.4 and 9.3.6, an error similar to the following might appear in the tabadmin.log:

2016-08-23 13:43:14.623 -0700_DEBUG_10.212.12.10:USTeam-SAML-VM_:_pid=7180_0x720bf653__user=__request=__ Upgrading configuration...
2016-08-23 13:43:14.639 -0700_DEBUG_10.212.12.10:USTeam-SAML-VM_:_pid=7180_0x720bf653__user=__request=__ Extracting default IDP entityID from metadata.
2016-08-23 13:43:14.670 -0700_FATAL_10.212.12.10:USTeam-SAML-VM_:_pid=7180_0x720bf653__user=__request=__ Unable to upgrade C:/ProgramData/Tableau/Tableau Server/config/tabsvc.yml to latest version
2016-08-23 13:43:14.686 -0700_FATAL_10.212.12.10:USTeam-SAML-VM_:_pid=7180_0x720bf653__user=__request=__ #<REXML::ParseException: The 'xml' prefix must not be bound to any other namespace (http://www.w3.org/TR/REC-xml-names/#ns-decl)

Environment

  • Tableau Server 9.1.1, 9.2.4,  9.3.6
  • Tableau Server 10.0
  • SAML Enabled

Cause

This behavior is related to a known issue that has been corrected in more recent releases.
Did this article resolve the issue?