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Error "ORA-12154" Connecting to Oracle


Published: 26 Aug 2014
Last Modified Date: 02 Apr 2015

Issue

When you try to open a published workbook that is connected to Oracle, or to connect to a published Oracle data source, the following error might occur: 
 
Oracle data error 12154: ORA-12154: TNS: could not resolve the connect identifier specified 
 

Environment

  • Tableau Server 8.2 and later versions
  • Oracle
  • Service and/or Port is included in the original connection to Oracle in Tableau Desktop

Resolution

Remove Service and/or Port from the connection by following these steps: 
  1. Download the published data source or workbook.
  2. In Tableau Desktop, open the published data source or workbook.
  3. Right-click the data source in the Data pane and then select Edit Data Source.
  4. Remove the values from the Service and/or Port fields. For more information, see Oracle
  5. Verify that the connection works.
  6. Republish the data source or workbook.
  7. In Tableau Server, test the connection.

Cause

Tableau Server is using Port and Service values that are in the TNSNames.ora file. These values should not be included in the connection details in Tableau Desktop when you first connect to Oracle.
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