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Error "No more spool space" When Refreshing a Teradata Extract


Published: 28 Jan 2016
Last Modified Date: 25 Oct 2017

Issue

When refreshing an extract from a Teradata connection, the extract fails with the following message:

"No more spool space"

Environment

  • Tableau Server
  • Teradata extract

Resolution

To resolve this issue, please work with your Teradata database administrator to investigate the following workarounds:
  1. Gather statistics on the underlying tables used in the extract.
  2. Consider increasing spool space in Teradata.

Cause

  1. Tableau is attempting to run a query against tables that do not have latest Stats gathered.
  2. Spool space is too small to handle the query Tableau is sending to Teradata.
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