Error ""netsh firewall" is deprecated;use "netsh advfirewall firewall" instead" in Tableau Server Logs

Published: 10 Sep 2013
Last Modified Date: 12 Jan 2017


The following error might appear in Tableau Server logs:
IMPORTANT: Command executed successfully.However, "netsh firewall" is deprecated;use "netsh advfirewall firewall" instead.For more information on using "netsh advfirewall firewall" commandsinstead of "netsh firewall", see KB article 947709at .


Tableau Server


No action is necessary. This message is informational only and can be disregarded. 

Additional Information

This message indicates that Tableau Server is communicating with your firewall using an older command. By itself, this message is meant only as a notification to developers that the older netsh firewall command has been replaced with the newer netsh advfirewall firewall command.  However, netsh firewall is still a valid command. This message can safely be disregarded as it indicates that the command completed successfully and is not an indication of an error. 
Did this article resolve the issue?