KNOWLEDGE BASE

Error "missing required context variable: account-id" Editing Google Analytics Data Source


Published: 16 Sep 2016
Last Modified Date: 13 Nov 2017

Issue

When editing the connection for Google Analytics extracts in Tableau Desktop 10.0 and 10.1, following error occurs:
Missing required context variable: account-id

Environment

  • Tableau Desktop 10.0.1 - 10.0.7
  • Tableau Desktop 10.1.0 - 10.1.5
  • Google Analytics

Resolution

  • Upgrade to Tableau Desktop 10.0.8, 10.1.6 or a newer version. For more information, see Upgrade Tableau Desktop
  • If you are unable to upgrade, as a workaround, create a new connection to Google Analytics and use Replace Data Source to replace the original connection.

Cause

This behavior is related to a known issue with id 592531 which has been corrected in more recent versions.
Did this article resolve the issue?