KNOWLEDGE BASE

Error "Exception from HRESULT" Connecting to PowerPivot


Published: 22 Jan 2013
Last Modified Date: 13 Oct 2014

Issue

When you try to connect to Microsoft PowerPivot, the following error might occur:

An error occurred while communicating with the data source
Exception from HRESULT: 0x800A03EC Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database.

Environment

  • Tableau Desktop
  • Microsoft PowerPivot

Resolution

  1. Open the PowerPivot file in Microsoft Excel.
  2. Delete the sheet that has pivot tables.
  3. Select PowerPivotPivotTable.
  4. In the dialog box that opens, select New sheet.
  5. Rename the new sheet if desired and save the Excel workbook. 
  6. Open Tableau Desktop and try connecting to PowerPivot again.

Cause

The "Exception from HRESULT" error occurs when the PowerPivot data is not linked to an Excel worksheet.
Did this article resolve the issue?