知识库

反复出现“Licensing Check In Progress”错误


发布时间: 11 Jul 2014
上次修改日期: 28 Mar 2018

问题

打开 Tableau Desktop 时,或者每几个小时,可能会出现以下错误:
 
正在进行许可检查
Tableau 仍在尝试确定系统上的可用许可证。必须先完成此任务,然后才能继续使用 Tableau。

环境

  • Tableau Desktop 
  • Windows

解决方案

上面的错误信息可能有几个原因。按照下面的说明从选项 1 开始,如果错误仍然存在,则转到下一个选项。

选项 1

通过右键单击应用程序图标并选择“以管理员身份运行”,来确保您以管理员身份运行 Tableau Desktop。

选项 2

在运行 Tableau Desktop 的计算机上,单击“开始”按钮,然后选择“所有程序”>“附件”>“运行”
  1. 输入 services.msc,然后单击“确定”
  2. 在“状态”列中,验证 FLEXnet Licensing ServiceFLEXnet Licensing Service 64 是否列为“已启动”。如果 FLEXnet 未列为“已启动”,则右键单击该服务的名称,然后选择“启动”

选项 3

如果选项 1 和 2 没有解决问题,请卸载并重新安装 Tableau Desktop。有关详细信息,请参见 Tableau 知识库中的升级 Tableau Desktop

选项 4

如果问题仍然存在,则此问题可能是未以管理员身份运行 FlexNet。确保许可证服务以管理员身份运行。若要让 Tableau 以最佳方式运行,请按照以下步骤将 FlexNet 可执行文件设置为始终以管理员身份运行
  1. 导航到 C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher
  2. 右键单击“FNPLicensingService64.exe”>“属性”>“兼容性”,并选中“以管理员身份运行此程序”
  3. 单击“确定”

选项 5

一些行为监控软件(如 Trend Micro OfficeScan)会在 Tableau 查找未知恶意软件行为时干扰其功能。

与您的 IT 安全团队合作,通过在行为监控系统下面将以下进程添加为“批准的程序”将 Tableau 和 FlexNet 列入白名单

C:\Program Files (x86)\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService.exe
C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService64.exe
C:\Program Files\Tableau\Tableau <version>\bin\tableau.exe
C:\Program Files (x86)\Tableau\Tableau <version>\bin\tableau.exe
C:\Program Files\Tableau\Tableau <version>\bin\tableau.exe
C:\Program Files (x86)\Tableau\Tableau <version>\bin\tableau.exe
 
注意:将“Tableau <version>”替换为计算机上安装的 Tableau 版本,例如 Tableau 10.3。

选项 6

按照 Tableau Desktop 安装疑难解答中的说明修复受信任的存储 #:4. 修复受信任的存储。
 

选项 7

如果上述步骤都不能解决该错误,请联系技术支持,并在“修复受信任的存储”下面包括您在上述步骤中创建的 LicResults.txt 文件。
 

原因

以下其中一项:
  • Tableau 或 FlexNet 未以管理员身份运行
  • 行为监控系统干扰了 Tableau 的功能
  • Tableau Desktop 未正确安装

其他信息

如果单击“管理产品密钥工具”中的“刷新”,则可能允许您继续工作,直到错误再次弹出。此错误并不妨碍 Tableau Desktop 工作,但可能会抑制生产力,因为清除此错误可能需要长达 5 分钟的时间。
此文章是否已解决问题?