KNOWLEDGE BASE

Error "Kerberos Authentication Failed" or "Sign in Failed" or "Tableau Server could not authenticate you automatically."


Published: 13 Feb 2015
Last Modified Date: 20 Jun 2017

Issue

When authenticating to Tableau Server via Kerberos, one of the following error messages might occur in Tableau Server:

In Tableau Server version 8.3.x:
 
Kerberos Authentication Failed
 
In Tableau Server version 9.x:
 
Sign in Failed 
 
Or:

Tableau Server could not authenticate you automatically.
Sign in using your Tableau Server credentials.
 

Environment

  • Tableau Server
  • Kerberos Authentication

Resolution

Option 1

Verify that your web browser is configured for Kerberos SSO. For more information, see Browser Support for Kerberos SSO.

Option 2

For Tableau Server 8.3.0-8.3.4 and 9.0.0, if the password for the Run As User contains special characters, generate a new keytab file using the ktpass command:
  1. Open the KerberosConfig.bat file generated by the Tableau Server Configuration utility. During the initial configuration, the Tableau Server Configuration utility will have prompted you to save this file to the default Tableau Server folder, for example: C:\Program Files\Tableau\Tableau Server\<version>\bin.
  2. Open the Command Prompt as an administrator, and then copy into it the bottom line from the KerberosConfig.bat file.
  3. Edit the command so that the %adpass% variable is enclosed in double-quotation marks, for example:

ktpass /princ HTTP/tableauserver.domain.lan@DOMAIN.LAN /pass "%adpass%" /ptype KRB5_NT_PRINCIPAL /out keytabs\kerberos.keytab
  1. Press Enter to run the command.
  2. Stop Tableau Server.
  3. In the Tableau Server Configuration utility, on the Kerberos tab under Step 3, enter the path to newly created keytab file.
  4. Start Tableau Server.
  5. From the computer running Tableau Desktop, remove any existing Kerberos tickets by running the following from a command prompt:

klist purge

Option 3

For Tableau Server 8.3.0-8.3.4 and 9.0.0, upgrade to the latest maintenance release of version 8.3 or 9.0. For more information, see Upgrade Tableau Server.

 

 

Cause

Apache is unable read the keytab file.

Additional Information

The following error might appear in the Apache gateway (httpd) error.log file:
 
gss_accept_sec_context() failed: Unspecified GSS failure.  Minor code may provide more information (, Wrong principal in request)
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