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Error "Invalid username, password, security token" Connecting to Salesforce


Published: 30 May 2013
Last Modified Date: 06 Dec 2016

Issue

When you try to connect to Salesforce from Tableau Desktop, one of the following errors might occur:
 
Internal Service Error: Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database. 

Or:
 
LOGIN_MUST_USE_SECURITY_TOKEN: Invalid username, password, security token; or user locked out. Are you at a new location? When accessing Salesforce--either via a desktop client or the API--from outside of your company’s trusted networks, you must add a security token to your password to log in. To receive a new security token, log in to salesforce.com at http://login.salesforce.com and click Setup | My Personal Information | Reset Security Token. 

Environment

  • Tableau Desktop 
  • Salesforce

Resolution

  1. Reset the security token in Salesforce. For more information, see Reset Your Security Token in Salesforce help. 
  2. When connecting to Salesforce from Tableau Desktop, add the security token to the end of your password. 
For example, if your password is ABCD and your security token is 1234, enter ABCD1234 as the password to log in to Salesforce from Tableau Desktop.

Cause

The Salesforce security token was missing or incorrect.
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