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Error "HTTP 503" or "HTTP 400" Viewing Dashboards After Upgrading


Published: 06 Dec 2013
Last Modified Date: 04 Jan 2017

Issue

When you try to open a published dashboard after upgrading to Tableau Server 8.1, one of the following errors might occur:
 
TableauException: HTTP 503: ERROR: The requested URL could not be retrieved
or:
TableauException: HTTP 503: A communication error occurred: "Operation timed out"
or:
TableauException: HTTP 400: Request Error (invalid_request)
or:
TableauException: HTTP 404: Object not found!
or:
Tableau Exception: HTTP 403 Error: The requested URL could not be retrieved
 
 

Environment

  • Tableau Server
  • Single computer installation
  • Data Server data source
  • Proxy

Resolution

Add a proxy exception for localhost:
  1. Use the Tableau Server Run As user account to sign in to Windows on the computer running Tableau Server, and then open Internet Explorer. For more information, see Run As User in Tableau Help.
  2. In Internet Explorer, select Tools > Internet options.
  3. On the Connections tab, click LAN Settings.
    The Use a proxy server for your LAN check box should be selected. If this check box is not selected, you are not using a proxy and the issue in this article doesn't apply. 
  4. Click Advanced
  5. In the Exceptions field, add localhost, and then click OK three times.
  6. Restart Tableau Server.

Cause

Tableau Server uses localhost to communicate between different components. This error occurs when the localhost URL is not accessible from the computer running Tableau Server. 

Additional Information

  • Tableau Server 8.0 and earlier versions use 127.0.0.1 for the connection between different components in single computer installations.
  • In distributed environments, all versions of Tableau Server use the IP addresses of the computers running Tableau Server.
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