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Error "Field ... does not exist" Connecting to Salesforce


Published: 18 Oct 2013
Last Modified Date: 05 Aug 2016

Issue

When connecting to Salesforce from Tableau Desktop, selecting the Accounts field in the connection dialog box sometimes results in the following error:

An error occurred while communicating with data source '<data source name>'
Field '[Account].[<field name>]', which is included in a join clause, does not exist. 

Environment

  • Tableau Desktop 
  • Salesforce

Resolution

One of the following solutions might resolve the issue, depending on the root cause.

Option 1: Edit the join used in the standard connection.

  1. Complete Step 1 and Step 2 in the Salesforce Connection dialog box.
  2. In Step 3, select Multiple Tables.
  3. In the table of join clauses, select the join clause that appears in the error message, and then click Remove.
Salesforce Connection

Option 2: Revise Permissions

Work with your Salesforce administrator to grant your user account permission to view the field.

Cause

Option 1

Tableau Desktop predetermines the standard connections, because most Salesforce accounts share the same base set of objects. This error occurs when the Salesforce account has been customized, and the names predetermined by Tableau Desktop do not match the names in the Salesforce account.

Option 2

The user profile does not have permission to view the field.
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