KNOWLEDGE BASE

Error "Failed to start the checklicense.exe ... Stopping dataengine and tabspawnde." Data Engine Not Started


Published: 18 Apr 2014
Last Modified Date: 08 Sep 2015

Issue

When starting Tableau Server, the data engine component does not start. Additionally, the following error message might appear in the Tableau Server log file:
 
Checking data engine licensing.
Failed to start the checklicense.exe
Unable to check license. Stopping dataengine and tabspawnde.

Environment

  • Tableau Server
  • Windows Server 2012

Resolution

Ensure the following:
  1. The Tableau Server Run As User account has Read and Execute permissions to the following folders and files:
    • C:
    • C:\Windows
    • C:\Windows\System32 (also force permissions change to the child objects)
    • C:\Windows\System32\cmd.exe
  2. The Run As User account has Full Control permissions to the folder where it is installed. Default location includes the following two folders:
    • C:\ProgramData
    • C:\Program files
  3. The Run As User account should have Log on as a service permissions set in the Local Security Policy.

Cause

The Run As User account does not have the correct permissions to start the data engine.
Did this article resolve the issue?