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Error "ERROR 99: Error communicating with HTTP proxy" Loading Preview After Publishing Workbook


Published: 06 Jul 2016
Last Modified Date: 13 Dec 2016

Issue

When publishing a workbook, the preview fails to load and he following error occurs:
An error occurred while trying to load the web page
ERROR 99: Error communicating with HTTP proxy 

Environment

Tableau Server 9.3

Resolution

  • Verify that the proxy server or load balancer is correctly configured. See Configuring Proxies for Tableau Server for more information. 
  •  Verify that the URL used to access the Tableau Server matches the setting in gateway.public.host. 

Cause

Proxy or load balancer is configured incorrectly. 
 

Additional Information

  • When publishing using Tableau Desktop, error may also be presented with a warning: "Data source <name> successfully published, but Tableau could not connect to the published data source. The workbook will continue to use the local data sources. To use the published data source, create a Tableau Server connection and replace the data source"
  • When viewing in Tableau Server, error may also be presented as "Internet communication error: could connect to server (<gateway.trusted.host>)" and "unable to connect to the server "<gateway.trusted.host>". Check that the server is running and that you have access privileges to the requested database."
  • Error may also be present in the Tableau Desktop Logs: "...tid":"f44","sev":"warn","req":"-","sess":"-","site":"{5DA61D8F-C3A5-4A73-AA9D-7BA1EA923992}","user":"-","k":"msg","v":Internet communication error: Couldn't connect to server\n (<gateway.trusted.host>).\n"}"
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