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Error "Check that the necessary drivers are installed" Refreshing Extracts


Published: 04 Mar 2014
Last Modified Date: 21 Jul 2015

Issue

When you try to refresh an extract on Tableau Online, the following error might occur:
 
com.tableausoftware.nativeapi.dll.DataSourceException: Unable to connect to the <data source type> Data Source. Check that the necessary drivers are installed and that the connection properties are valid.

When you then try to edit the data connection from Tableau Online, the following error might occur:
 
The drivers necessary to connect to the database server '<server name>' are not properly installed on Tableau Server. Visit http://www.tableausoftware.com/drivers to download driver setup files.

Environment

Tableau Online

Resolution

Extract refreshes can be pushed to Tableau Online using Tableau Desktop or the command-line utility. For more information, see Keep Data Fresh in Tableau Help.
 

Cause

Tableau Online currently supports live data connections to the following data sources: 
  • Google BigQuery 
  • Amazon Redshift 
  • MySQL
  • PostgreSQL
  • Microsoft SQL Server
For scheduled refreshes, Tableau Online supports the following data sources: 
  • Google BigQuery 
  • Amazon Redshift 
  • Google Analytics 
  • Salesforce 
  • MySQL
  • PostgreSQL
  • Microsoft SQL Server
All other data sources must first be extracted.
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