KNOWLEDGE BASE

Error "drivers . . . not properly installed" Opening View with Vertica Connection


Published: 18 Jul 2014
Last Modified Date: 29 Aug 2014

Issue

On Tableau Server, when you try to view a workbook that was created on Windows and that includes a Vertica connection, the following error might occur:

DataSourceException: The drivers necessary to connect to the database server '<server>' are not properly installed on Tableau Server. Visit http://www.tableausoftware.com/drivers to donload driver setup files. [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

Environment

  • Tableau Server 8.2.0 and 8.2.1
  • Windows
  • Vertica

Resolution

Option 1

Upgrade to Tableau Desktop and Tableau Server 8.2.2 or a later version. For more information, see Upgrading Tableau Desktop and Upgrading Tableau Server in the Tableau Knowledge Base.

Option 2

Make sure that the version of the Vertica driver on the computer running Tableau Desktop matches the version on the computer running Tableau Server. 

Cause

This behavior is a known issue that has been corrected in more recent releases.
Did this article resolve the issue?