KNOWLEDGE BASE

Error "DataSourceException: <p> To connect to the <database name> database, you must install at least version <number> of the driver." When Publishing A Workbook


Published: 19 Dec 2015
Last Modified Date: 07 Mar 2017

Issue

When publishing a workbook to Tableau Server, the following error might occur:

DataSourceException: <p> To connect to the <database name> database, you must install at least version <version number> of the driver.

 

Environment

  • Tableau Desktop
  • Tableau Server

Resolution

Option 1 

Work with your IT department to confirm which SQL Server Native Client driver is installed on the computer running Tableau Desktop, and then install the correct version of the driver from the Drivers & Activation page. Once the driver matching your version of MS SQL has been downloaded, install it to Tableau Server (and all nodes if this is a distributed installation).

You can verify the installed version of the SQL Server Native Client driver by going to Control Panel > Uninstall Program.

Option 2

If you are attempting to publish a workbook that is connected to an extract, such extract may not have been successfully created or published if it occurred during a Tableau Server restart. To resolve the error, please delete and recreate the extract.

 

Cause

SQL Server Native Client driver installed is not compatible with the database version.
Did this article resolve the issue?