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Error "Data Engine Error: 8: target machine actively refused it"


Published: 07 May 2013
Last Modified Date: 02 Sep 2014

Issue

When you try to access views on Tableau Server, the following error might occur:

Session Ended by Server

DataSourceException: Tableau Data Engine Error: 8: No connection could be made because the target machine actively refused it. - IPC_Socket::Connect(socket::connect::connect host="<ip-address>", port=27042)
<date> <time> (UYlCTAoPCoIAAHGYI3EAAADH,0,1)

 
Also, when accessing the Background Tasks administrative view,  you may see a similar error message display in the Extract Purge or Reap failures tooltips:

 
 

Environment

Tableau Server

Resolution

To resolve this issue, follow the procedures in each of the following sections.

Step 1: Verify and set permissions for the Tableau Server Run As User account

  1. Open the Command Prompt as an administrator and type the following command:
    ICACLS "C:\ProgramData\Tableau" /grant "<domain-name>\<run-as-user-account-name>:(OI)(CI)(F)"
     Note: Replace "C:\ProgramData\Tableau" with the path to the location of the Tableau Server data directory. Replace <domain-name> with the domain that the machine belongs to and <run-as-user-account-name> with the name of the Run As User account used by Tableau Server.
  2. (Optional) In some cases, you might have to type the following command:
    • Tableau Server 8.1 and later versions: ICACLS "C:\Program Files\Tableau" /grant "<domain-name>\<run-as-user-account-name>:(OI)(CI)(F)"
    • Tableau Server 8.0 and earlier versions
      • On a 32-bit computer: ICACLS "C:\Program Files\Tableau" /grant "<domain-name>\<run-as-user-account-name>:(OI)(CI)(F)"
      • On a 64-bit computer: ICACLS "C:\Program Files (x86)\Tableau" /grant "<domain-name>\<run-as-user-account-name>:(OI)(CI)(F)"
    ​Note: Replace "C:\Program Files (x86)\Tableau" or "C:\Program Files\Tableau" with the path to the location where Tableau Server is installed. Replace <domain-name> with the domain that the machine belongs to and <run-as-user-account-name> with the name of the Run As User account used by Tableau Server.
  3. Type the following commands:
    • Tableau Server 8.1 and later versions: cd C:\Program Files\Tableau\Tableau Server\<version>\bin
    • Tableau Server 8.0 and earlier versions
      • On a 32-bit computer: cd C:\Program Files\Tableau\Tableau Server\<version>\bin
      • On a 64-bit computer: cd C:\Program Files (x86)\Tableau\Tableau Server\<version>\bin
    • tabadmin restart 
  4. Verify that the views on Tableau Server are now accessible.
Note: In Tableau Desktop 8.1 and later versions, if you installed the 32-bit Tableau Server on a 64-bit operating system, the default path will be C:\Program Files (x86)\Tableau\Tableau Server\<version>bin.

Step 2: Stop Tableau Server

  1. Back in the Command Prompt, type the following command to stop Tableau Server: tabadmin stop
  2. Check for the following:
    • All Tableau Server processes are stopped.
    • If any processes are still running after Tableau Server is stopped, manually end those processes.
    • Verify that all Tableau Server configuration files are present and not corrupted.
  3. In the Command Prompt, rewrite the configuration files by typing the following command: tabadmin config
  4. Start Tableau Server again by typing the following command: tabadmin start
    • Verify that Tableau Server is working.

Cause

This issue can occur for the following reasons: 
  • Tableau Server lacks sufficient permissions to the underlying file system to perform a task that requires modifying a file.
  • The Tableau Server machine is unable to access the file system due to insufficient disk space.

Additional Information


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