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Error "Connection attempt failed" Refreshing Vertica Extracts


Published: 16 Dec 2014
Last Modified Date: 27 Apr 2016

Issue

When refreshing an extract of a Vertica data source, the following error might occur: 

com.tableausoftware.nativeapi.dll.DataSourceException: [Vertica][VerticaDSII](160) Connection attempt failed: server closed the connection unexpectedly
This probably means the server terminated abnormally before or while processing the request
Unable to connect to the server "10.130.64.77". Check that the server is running and that you have access privileges to the requested database

Environment

  • Tableau Server 8.2.4
  • Vertica

Resolution

Work with your Vertica Database Administrator to ensure Tableau Server has permissions to access the tables and views the extract is based on in the underlying data source.

Cause

Tableau Server does not have permission to access the database tables the extract is based on.

Additional Information

Data sources using different tables and views on the same Vertica database may refresh successfully.
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