KNOWLEDGE BASE

Error Connecting to Hortonworks Hadoop: Unexpected GSS Failure (Ticket Expired)


Published: 14 May 2018
Last Modified Date: 15 May 2018

Issue

When trying to connect to Hortonworks Hadoop, an error may occur:

[Hortonworks][Hardy] (34) Error from Server: SASL(-1): generic failure: GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (Ticket expired)

Environment

  • Tableau Desktop 10.5.3
  • Windows 7
  • Hortonworks Hadoop Hive

Resolution

To get a new ticket, there is a command called "kinit" that can be run from the command line of your computer. You may need to install the MIT Kerberos software first: http://web.mit.edu/KERBEROS/dist/index.html

  1. Open the Start menu and type in CMD to open the command line.
  2. Navigate to the folder that contains the Kerberos software.
  3. Type kinit and press the Enter key.

If you receive an error when using the kinit command, verify that you have a Ticket Granting Ticket (TGT) by typing this command in the command line:

klist tgt

If there is no TGT listed, please contact your Windows Administrator or IT Team for their assistance in configuring the Kerberos system on your computer.

Cause

A Kerberos ticket on the computer is expired and needs to be refreshed.
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