KNOWLEDGE BASE

Error "Cleaned up crashed job" Refreshing Extracts


Published: 13 May 2016
Last Modified Date: 08 Mar 2017

Issue

When backgrounders are running extract jobs, jobs might fail with the message:

Cleanup up crashed job

Additionally, the following messages are found in the logs:

<timestamp> (,,,) localhost-startStop-1 : INFO com.tableausoftware.backgrounder.runner.BackgroundJobRunner - Blocking on backgrounder startup lock
<timestamp> (,,,) localhost-startStop-1 : INFO com.tableausoftware.backgrounder.runner.BackgroundJobRunner - Lock acquired. Another backgrounder ran server startup tasks.
<timestamp> (,,,) localhost-startStop-1 : INFO com.tableausoftware.model.workgroup.service.BackgroundJobService - Cleaned up crashed job 1918666 'Refresh Extracts'
<timestamp> (,,,) localhost-startStop-1 : INFO com.tableausoftware.backgrounder.AppLifecycle - AppLifecycle started successfully.

Environment

Tableau Server 9.2.4 - 9.2.8
Tableau Server 9.3.0 - 9.3.2

Resolution

Upgrade to Tableau Sever 9.2.9, 9.3.3 or a newer version. For more information, see Upgrading Tableau Server.
 

Cause

This behavior is related to a known issue which has been corrected in more recent versions.
 
Did this article resolve the issue?