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Error “Checkout failed: -31” During Activation


Published: 20 May 2013
Last Modified Date: 25 May 2016

Issue

When activating a license, you may encounter the following error:

Checkout failed: -31

Environment

Tableau Desktop

Resolution

  1. Verify that the date and time on the system clock is accurate.

    If the system clock is set to a date earlier than the product key's start date, Tableau Desktop cannot be activated.

  2. Verify that the FLEXnet Licensing Service is started in the Services Console.
    • Select Start menu > Run and type: services.msc
    • Verify that FLEXnet Licensing Service is listed as Started on the machine.
    • If it is not listed as Started, right-click it and select Start

Repair the trusted storage where the activation is saved by completing the following steps:

  1. Open the Command Prompt as an administrator and change to the Tableau Server bin directory. For example:

    cd C:\Program Files\Tableau\Tableau <version>\bin

  2. Run the following command: custactutil -localrepair
  3. Start Tableau.

If running the above command does not resolve the issue:

  1. Run the following command:

    custactutil -view > LicResults.txt

  2. Send the LicResults.txt file, or a screen shot of the command window showing the results, to Tableau Support.

Cause

Trusted Storage was corrupted.

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