KNOWLEDGE BASE

Error "Cannot connect to IBM DB2 databases"


Published: 13 Mar 2013
Last Modified Date: 05 Dec 2016

Issue

When trying to connect to an IBM DB2 database from Tableau Desktop, you may see the following error message:

Tableau cannot connect to IBM DB2 databases running on iSeries mainframes.  Consult IBM documentation on strategies that could allow Tableau to connect to your data source.
DB2 database error 0x80004005:  SQL8002N  An attempt to connect to a host failed due to a missing DB2 Connect product or invalid license.


 

Environment

  • Tableau Desktop
  • Tableau Server
  • IBM DB2 on iSeries platform

Resolution

Connecting to an IBM DB2 data source on iSeries platform is currently not supported. However, you may have some success connecting to this data source on the ISeries platform using the following suggestions:  
 
  • Connect to DB2 using the generic ODBC connection (Other Databases (ODBC)). While it may be possible to connect to DB2 using the generic ODBC data connection, success often varies and full compatibility with Tableau features cannot be guaranteed. For more information about the capabilities and limitations of connecting to unsupported data sources using the generic ODBC connections, see the following articles: 
  • Mirror the data source onto a supported data source. When working with DB2 data sources on the iSeries platform, you can mirror the data source onto a supported data source like pSeries or xSeries platforms, and then connect to the database using the native DB2 data connection.

Cause

Connecting to IBM DB2 is not supported on iSeries platforms.

 

Additional Information

For a full list of supported data sources, see the Technical Specifications page.
 
DB2 SeriesAlternate NamesSupported?
iSeriesOS/400; AS/400;DB2/400;No
zSeriesz/OSYes, starting with Tableau Desktop 8.2.5+
xSeriesDB2 for Linux, UNIX and Windows v9.1 or laterYes
pSeriesDB2 for Linux, UNIX and Windows v9.1 or laterYes
Did this article resolve the issue?