KNOWLEDGE BASE

Error: "Bindings could not be resolved for relation [TableauSQL]" When Validating Custom SQL Queries


Published: 27 Jun 2017
Last Modified Date: 17 Aug 2017

Issue

When validating a Custom SQL query in the UI interface, the following error might occur in Tableau Desktop: 
"Bindings could not be resolved for relation [TableauSQL]."

Environment

  • Tableau Desktop
  • Cloudera Hadoop Hive

Resolution

  1. Check the version of the driver: Start > ODBC Data Source Administrator (64 bits) > Drivers tab > Cloudera ODBC Driver for Apache Hive > Version
  2. Uninstall the existing Cloudera driver as any software.
  3. Install a different driver version.
  4. Restart Tableau Desktop and try to use Custom SQL feature again.

Cause

The version 2.5.28 Cloudera Hadoop Hive driver is not compatible with Tableau Desktop. 
Did this article resolve the issue?