KNOWLEDGE BASE

Error "API_CURRENTLY_DISABLED: API is disabled for this User" Connecting to Salesforce


Published: 30 Dec 2013
Last Modified Date: 25 Apr 2016

Issue

When connecting to Salesforce in Tableau Desktop, the following error might occur.

API_CURRENTLY_DISABLED: API is disabled for this User.

Environment

  • Tableau Desktop
  • Salesforce.com

Resolution

  1. Navigate to the Salesforce user profile for the affected user.
  2. Under Administrative Permissions, ensure that the API Enabled box is selected.

Cause

Salesforce API access is disabled for the user attempting to create the connection.
Did this article resolve the issue?