KNOWLEDGE BASE

Tableau Data Engine Error 4 When Working with Extracts


Published: 04 Feb 2013
Last Modified Date: 11 Jan 2017

Issue

When you run an incremental extract or try to create a large extract, you might receive one of the following errors:

Tableau Data Engine Error 4: There is not enough space on the disk.

Or

Tableau Data Engine Error: 4: PackageDatabase: failed
...
Unable to create extract

Or

Tableau Data Engine Error: 4: Insufficient system resources exist to complete the requested service
An error occurred while communicating with data source ''. The connection to the data source might have been lost.
Tableau Data Engine Error: 8: Insufficient system resources exist to complete the requested service. -IPC_NamedPipe::Send(WriteFile)
Unable to create extract
Tableau Data Engine Error: 8: Insufficient system resources exist to complete the requested service. -IPC_NamedPipe::Send(WriteFile)
Or
 
The connection to the data source might have been lost.
Communication with the Tableau Protocol Server process was lost.
Unable to create extract.

 
This error might occur when you try to connect to Salesforce, because Tableau Desktop imports data from Salesforce by creating an extract.

Environment

Tableau Desktop

Resolution

Try any of the following tasks to troubleshoot the issue:

  • Empty the Windows TEMP folder (default location: C:\TEMP).
  • Limit the size of the extract.
  • Use Tableau Desktop on a 64-bit computer.
  • Close other applications that you are not actively using.

Cause

  • When you take an extract, Tableau Desktop, as well as some data engines, create temporary files as part of the process. Generally when this error occurs, there is not enough disk space on the drive on which the Windows TEMP folder resides.

    The TEMP folder might need as much as the square of the final size of the extract. For example, a 32GB extract may require up to 1024GB (1TB) of disk space to create the extract.

  • The error could also occur if Windows does not have enough contiguous blocks of memory available.

    For more information, see Out of Memory Errors in Tableau Desktop.

Did this article resolve the issue?