KNOWLEDGE BASE

"ERROR 2656: Column unicode.�ス�ス�ス�ス�スフ優�ス�ス�スx does not exist" When Connecting to HP Vertica


Published: 13 Apr 2016
Last Modified Date: 23 Jan 2017

Issue

When connecting to HP Vertica the following  error occurs:

ERROR 2656: Column unicode.�ス�ス�ス�ス�スフ優�ス�ス�スx does not exist

Environment

  • Tableau Desktop 9.3.0 and earlier versions
  • Vertica
  • Japanese or Chinese Unicode Characters

Resolution

Option 1:

Upgrade to Tableau Desktop 9.3.1 or later. For more information, see Upgrade Tableau Desktop


Option 2:

Use one of the following workarounds: 
  • Uninstall current Vertica drivers and install HP Vertica Driver version 6.1.3. 
  • Use the generic ODBC connector and select Report Unicode columns as char.
  • Place the attached vertica utf.tdc in the following directories: 
    For Tableau Desktop on Windows: Documents\My Tableau Repository\Datasources 
    For Tableau Server: Program Files\Tableau\Tableau Server\<version>\bin 
Note: Tableau does not test or support TDC files. These files should be used as a tool to explore or occasionally address issues with your data connection. Creating and maintaining TDC files requires careful manual editing, and there is no support for sharing these files.

Cause

This behavior is related to a known issue which has been corrected in more recent versions.
Did this article resolve the issue?