KNOWLEDGE BASE

Connection to Excel is Successful But No Tables Are Available


Published: 24 May 2016
Last Modified Date: 26 Sep 2016

Issue

When you try to connect to an Excel workbook, the connection is successful, but no tables are available. 

 

Environment

  • Tableau Desktop 9.0 - 9.3
  • Excel

Resolution

Option 1: 

Upgrade to Tableau Desktop 9.2.12, 9.3.4 or a newer version. For more information, see Upgrading Tableau Desktop

Option 2:

Ensure that the underlying Excel worksheet contains a column header. 
 

Cause

This behavior is related to a known issue which has been corrected in more recent versions. 
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