KNOWLEDGE BASE

Computer Stops Responding When Using Custom SQL


Published: 16 Aug 2013
Last Modified Date: 22 Jul 2016

Issue

When you try to connect to a specific query by selecting Custom SQL in the connection dialog box, the computer hosting Tableau Desktop might stop responding and an error message might display on a blue screen.

Environment

  • Tableau Desktop
  • Symantec Endpoint Encryption and Full Disk Encryption RU3 and earlier versions

Resolution

Option 1:

Upgrade to Symantec Endpoint Protection RU4 or later versions.

Option 2:

Create a smaller custom SQL script to prevent the Symantec Protection buffer from over running.
 

Option 3:

Work with Symantec Support or enlist your IT Team to disable Symantec Endpoint Encryption.

Cause

Symantec has identified the source of the issue to be their Symantec Endpoint Encryption(SEE)+Full Disk Encryption software preventing a buffer overrun. Symantec has a Page_Buffer setting of 4096 bytes. When Tableau Desktop uses the Custom SQL option, the system registry is used temporarily to save the custom SQL. When using a large custom SQL statement, the Symantec Endpoint Protection buffer protection is triggered, causing the computer to stop responding.

Additional Information

The issue occurs with any data source, when using very long custom SQL statements.
Did this article resolve the issue?