KNOWLEDGE BASE

Tables Missing or Errors Received Connecting to Splunk


Published: 30 Apr 2015
Last Modified Date: 27 Dec 2016

Issue

When connecting to Splunk from Tableau Desktop, tables might not appear, or the following error might occur: 
""An error occurred while communicating with data source ". Invalid username or password. [Splunk][SplunkODBC](160) Unauthorized. Invalid username or password." 

Environment

  • Tableau Desktop
  • Splunk

Resolution

  • Connect to the data source using Port 8090.
  • Connect to the host using HTTPS instead of HTTP. 

Cause

The connection does not utilize the default Splunk Management port, or the standard HTTPS: prefix was not used to connect.

Additional Information

The following error may be found in the Tableau Desktop logs:

[Splunk][SplunkODBC] (60) Unexpected response from server. Veriy the server URL. Error parsing JSON: Expect either an object or array at root
Did this article resolve the issue?