KNOWLEDGE BASE

Blank Dashboard after Publishing


Published: 30 Jul 2013
Last Modified Date: 11 Aug 2016

Issue

Dashboard is blank after publishing to Tableau Server.

Environment

Tableau Server 

Resolution

Tableau Server 9.2.4 and earlier

Upgrade to Tableau Server 9.2.4 or later. For more information, see Upgrading Tableau Server.

Tableau Server 9.2.4 and later

Rename the data source and republish the workbook.
  1. Select the data source from the Data menu and select Rename.
  2. In the Rename Connection dialog box, type a new name, and click OK.
  3. Select Server > Publish Workbook to republish the workbook to Tableau Server.
Alternatively, you can publish the data source as a live connection to Tableau Server. Then, whenever the underlying data changes, republish the data source. This action will force all workbooks that use the data source to pick up the new data , which will have the new metadata.

Cause

This issue occurs when:
  • A new field is added to the underlying data source, and then used in a view inside a dashboard.
  • A field that is used in a view inside the dashboard is deleted or renamed in the underlying data source.
Tableau Server will not automatically detect data type changes. The data connection definition and metadata is tied to the data connection name. 
 

Additional Information

The Refresh command in Tableau Desktop will refresh the connection. This is because Tableau Desktop can only have one user; refreshing the connection only affects that single user. If the Tableau Server Refresh command worked in the same way, the connection would cause a query cache miss for Tableau Server users in the same process. For this reason, the Refresh command on Tableau Server runs only new queries, rather than refreshing the connection.
 

 

 
Did this article resolve the issue?