KNOWLEDGE BASE

Action Filter Resets Quick Filter


Published: 01 May 2014
Last Modified Date: 15 Feb 2017

Issue

When you make selections in a quick filter and then click an action filter, the quick filter selections might be cleared.

Environment

Tableau Desktop

Resolution

Option 1: Modify the Filter Action

  1. Open the workbook in Tableau Desktop.
  2. Navigate to the dashboard, and select Dashboard > Actions.
  3. Select the Filter Action, and then click Edit.
  4. Under Target Filters, select Selected Fields.
  5. Click Add Filter.
  6. In the Source and Target drop-down menus, choose the desired field to filter, and then click OK three times.

Option 2: Apply the Quick Filter to Selected Sheets

  1. Open the workbook in Tableau Desktop, and navigate to the sheet that contains the quick filter.
  2. Right-click the field on Filters, and select Apply to Worksheets > Only this Worksheet or Apply to Worksheets > All Using this Data Source.

Cause

This behavior is a known issue that has been corrected in more recent releases.
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