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When Publishing a live query with Tableau Bridge, an error containing "Unable to connect to the server "(DB IP address)" " is encountered


Published: 30 Dec 2017
Last Modified Date: 01 Feb 2018

Issue

When publishing a data source using Tableau Bridge live query connection, the following error occurs:
 
"The Tableau Bridge client is not connected. Ask your site administrator to repair the client. Unable to connect to the server "10.0.200.37". Check that the server is running and that you have access privileges to the requested database. 
DataServiceFailure 

Unable to connect to the server "us-east-1.online.tableau.com". Check that the server is running and that you have access privileges to the requested database."

Environment

  • Tableau Online 10.4.2
  • Tableau Bridge
  • Windows 10
  • MS SQL Server

Resolution

Set up Tablau Bridge to Run as a Service, instead of Application. See the "Additional requirements specific to maintaining live connections" section near the bottom of the Use Tableau Bridge to Expand Data Freshness Options on the Tableau Online Product Help webpage.

 

Cause

To publish a data source with a live connection, Bridge must be set up to Run as a Service
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