KNOWLEDGE BASE

Tableau Data Engine Error: 40281: bad node type Unable to connect to the server "localhost"


Published: 12 Jun 2017
Last Modified Date: 23 Jun 2017

Issue

Some workbooks are unable to connect to their extracts after a Tableau Server restore, and the following error occurs:
Tableau Data Engine Error: 40281: bad node type Unable to connect to the server "localhost"

Environment

  • Tableau Server
  • Extracts

Resolution

  1. Disable or remove any 3rd party backup tools or hard drive maintenance tools which are currently active on the computer running Tableau Server.
  2. Download the affected extracts, refresh, and republish.
  3. Create a new .tsbak file and restore it to a test environment to confirm that the issue is resolved.
To prevent this issue from reoccurring, make sure that any "Tableau Data Engine Error: 40281" messages are resolved prior to taking a backup of Tableau Server.
 

Cause

A 3rd party tool used for either hard drive maintenance or VM backup caused issues with the extracts during the Tableau Server backup process. 
Did this article resolve the issue?