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Error "select() failed: The pipe has been ended. (0x0000006D/109)" Creating or Querying Extracts on AWS


Published: 16 Feb 2018
Last Modified Date: 18 May 2018

Issue

While creating or querying extracts on a computer hosted on an Amazon EC2 c5 (large) or m5 (4xlarge) instance, Tableau's Hyper process quits unexpectedly and an error similar to the following occurs:
Unable to connect to the data source. 
Try connecting again. If the problem persists, disconnect from the data source and contact the data source owner. 
PQstatus: 1, could not connect to the server. Connection refused (0x0000274D/10061)
OR
select() failed: The pipe has been ended. (0x0000006D/109)

Additionally, refreshing a published extract via Tableau Bridge may result in the associated workbook displaying no data.

Environment

  • Tableau Desktop 10.5.0 - 10.5.1
  • Tableau Server 10.5.0 - 10.5.1
  • Tableau Bridge
  • Tableau Online
  • Extracts and text files
  • Amazon AWS m5 and c5 (xlarge) instances

Resolution

If using Tableau Online: Upgrade Tableau Desktop to 10.5.2

If using Tableau Server: Upgrade Tableau Desktop and Tableau Server to 10.5.2

For more information, see Upgrade Tableau Desktop and Upgrade Tableau Server.

Cause

This behavior is related to a known issue with ID 723876 which has been resolved in a more recent version.
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