KNOWLEDGE BASE

Error "Database error 0x80040154: Class not registered" Connecting to 64-bit Excel


Published: 03 Feb 2016
Last Modified Date: 13 Mar 2017

Issue

When you try to connect to a Microsoft Excel file, the following error might occur: 
The drivers necessary to connect to this database are not properly installed…
Database error 0x80040154: Class not registered.
Unable to connect to the Microsoft Excel file "filename" Check that you have access privileges for the requested file and that it is not open in another application.

Environment

  • Tableau Desktop
  • Tableau Server
  • Microsoft Windows
  • Microsoft Office 2012 and newer versions (64-bit) 

Resolution

  1. Visit our Drivers page.
  2. Install the drivers for Microsoft Access (the Microsoft Access Database Engine 2010).  
For Tableau Server, install the drivers on all computers in the distributed environment, then restart Tableau Server.​

Cause

Microsoft Excel 2012 and newer versions typically install a 64-bit version of the Microsoft Access Database Engine drivers. Installation of these drivers removes the 32-bit version of the driver that Tableau Desktop and Server needs to access file-based data sources such as Excel, Access, and CSV. 
Did this article resolve the issue?