KNOWLEDGE BASE

Action Filter Not Working On Safari & Chrome On Ipad


Published: 01 Apr 2016
Last Modified Date: 16 Aug 2017

Issue

When attempting to use an Action Filter in a Dashboard opened in Safari on Ipad the Target Dashboard is not displaying, although it is displaying in all Browsers on a Computer
 

Environment

  • Tableau Server 9

Resolution

This behavior has been identified as "By Design". At this stage there are two valid workarounds to consider: 

Option 1

Specify client-side rendering for the viewing of the view in the browser by appending "?:render=true". 
This setting can also be made Global to Tableau Server Environment by using the tabadmin options vizqlserver.browser.render to enable client-side rendering and vizqlserver.browser.render_threshold and vizqlserver.browser.render_threshold_mobile to change the thresholds for client-side rendering. 

For more information please review the Online Help about tabadmin set options linked below: 


Option 2

Users can turn off popup blocking in their browser: 
  1. By adding a site exception in most browsers; e.g. Chrome, FF, and IE. 
    Please refer to the following Google Knowledge Base article: Block or allow pop-ups in Chrome 
     
  2. By turning off all popup blocking in Safari. 
    To do so access Safari >Preferences>Security and uncheck "Bloc pop-up windows". 
     

Cause

It appears that the issue reside in the fact that when accessing a View on Tableau Server using Safari, it is defaulting to Server Side Rendering.

Adding "?:render=true" at the end of URLs will force the Client to render the visualization, which should allow the action to work as desired.
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