知识库

更改数据提取的文件路径


发布时间: 08 Mar 2014
上次修改日期: 02 Mar 2018

问题

如何更改 Tableau Desktop 中数据提取数据文件的位置。

环境

  • Tableau Desktop
  • 数据提取

答案

  1. 如果有 .twbx 文件,请使用以下方法之一将 .twbx 文件转换为 .twb 文件:
    • 在 Tableau Desktop 中,打开打包工作簿(.twbx 文件),然后选择“文件”>“另存为”。在“保存类型”下,选择“Tableau 工作簿 (*.twb)”
    • 在 Windows 资源管理器中,右键单击 .twbx 文件,然后选择“解包”
  2. 在 Tableau Desktop 中,打开 .twb 文件。单击工作表标签,然后选择“数据”>“<数据源名称>”>“数据提取”>“移除”
  3. 选择“移除数据提取”,然后单击“确定”
  4. 选择“数据”>“<数据源名称>”>“提取数据”,然后单击“数据提取”
  5. 选择所需的位置,然后单击“保存”

注意: 如果您有仅数据提取数据源,请返回到数据源选项卡并重新创建数据源,同时选择一个新的保存位置。

其他信息

您是否会收到指定数据提取位置的提示取决于若干因素。
  • 如果工作簿是连接到数据提取 (.tde) 的 .twb(解包工作簿),则对数据提取所做的任何更改将保存到在创建原始数据提取时指定的位置。如果您刷新或重新创建数据提取而不移除以前的数据提取,则不会要求您指定新文件位置。如果您移除数据提取然后创建一个新数据提取,则会提示您为数据提取选择文件位置。
  • 如果工作簿是连接到数据提取的 .twbx(打包工作簿),则对数据提取所做的任何更改将保存到 Tableau 临时文件夹。在移除数据提取并创建新数据提取时,将不会提示您选择文件路径。若要解决此限制,您必须先将 .twbx 文件转换为 .twb 文件。
若要查看这些步骤的实际运行效果,请观看下面的视频。
注意:视频没有声音。

 
此文章是否已解决问题?